grey

Widgets and 3 column layout

Vote 0 Votes

I am using the 3 column layout thin-wide-thin of Cityscape London.

I created a widget template with a picture and some text. I clicked on 3-column layout - Primary Sidebar and removed the widgets i didnt want. The only widgets I selected were the one I created and the calendar widget.

For 3-column layout - Secondary Sidebar, I added recent entries, monthly archive dropdown and search.

However when i publish my site, all the widgets appear on the left sidebar and the right sidebar is empty.

I tried it in reverse, putting my custom made widget on the secondary side bar and the others on the primary and it works fine. Anyone have any ideas:

You can see my blog at www.greyday.co.uk

Thanks

Reported on Movable Type 4.1x

10 Replies

| Add a Reply
  • Did you check the HTML generated in the first scenario to see if the two sidebars, <div>s named beta and gamma, had content in them?

  • Pretty new to MT, which html should I be looking for. Seems ive done something incorrect the widgets are not even showing now on my main page. Just the entries.

  • My sidebar template is as follows Mike if you can notice anything odd:



















  • Just open up the index.html file and see if the contents of beta and gamma are empty or not when you go back to the first layout style you wanted. IIRC, beta is the primary, gamma the secondary toolbar div tags.

  • I checked Index.html:
    Alpha:

    Gamma:


    Recent Entries

      Im tempted to delete the blog and start again. I can't see what I have done to mess the whole thing up:(

    • Alpha is the main content area.

      Beta is the primary toolbar.

      Gamma is the secondary toolbar.

      What was in Beta when you reverted back to your original settings that you tried to create for a 3 column layout?

    • If you haven't deleted your blog already, do this:

      I created a widget template with a picture and some text. I clicked on 3-column layout - Primary Sidebar and removed the widgets i didnt want. The only widgets I selected were the one I created and the calendar widget.

      For 3-column layout - Secondary Sidebar, I added recent entries, monthly archive dropdown and search.

      Then post the HTML here. To make it readable on this post, do the following in a text editor:

      Replace all

      Replace all > with &gt;

    • Thanks so much for helping Mike, as it was a new blog with limited entries I just deleted it and started again. I will get the appearance etc how I want it before posting any entries. Hopefully that will make life easier.

      Once again thanks for your help.

    • carrieoke13

      So I am having the exact same problem as the original poster. I'm using Unity Green thin, wide, thin, but all of my widgets are showing up in the left sidebar instead of left and right. I looked at the generated html for the page and in the div tag for gamma, it DOES show content. here's the link to the page:

      http://impatientscrapper.com/blog/

      the bottom two widgets should be in the secondary sidebar.

      any help would be greatly appreciated! thanks!

    • carrieoke13

      Hi - sorry to post twice so close together, but I figured out the issue. I had neglected to add a tag to the widget I created. check your divs if you are having this same issue!
      thanks!

    Add a Reply

    If you need to share template code, replace all the "<" signs with "&lt;" or use this utility.

    Forum Groups

    code.sixapart.com

    137 479

    Last Topic: Getting a thumbnail with xpath by Peter on Mar 13, 2011

    238 797

    Last Topic: Manifest Schema Compatibility Issue When Restoring Blog by Matt on Oct 17, 2012

    1858 6594

    Last Topic: Categories and Basename Publishing Issues by e21media on Oct 25, 2012

    88 307

    Last Topic: absolute publish date in Manage Entries screen by .mau. on Apr 18, 2012

    1488 5347

    Last Topic: Anti-cloning by .mau. on Oct 29, 2012

    732 3093

    Last Topic: Blog moved server - now users cannot access blog? by mowgs on Oct 30, 2012

    89 317

    Last Topic: How to "pretify" a url in htaccess with a few wildcards by Caio on May 30, 2012

    183 771

    Last Topic: Commenting with TypePad by Rob Ferrara on Oct 17, 2012

    212 680

    Last Topic: Does MT-Approval work in MT5? by DLpres on Sep 25, 2012

    27 100

    Last Topic: Upgrading MT by Caio on Oct 15, 2012

    49 224

    Last Topic: Movable Type 6 Ideas by Caio on May 28, 2012

    65 248

    Last Topic: Expanding new rich text editor and implementing table function by Takeshi Nick Osanai on Jul 30, 2012